Data Loading Issue

Incident Report for Ometria

Resolved

This incident has been resolved.
Posted Jun 25, 2025 - 00:00 BST

Identified

The issue has been identified and a fix is being implemented.
Posted Jun 24, 2025 - 23:53 BST

Investigating

We are currently investigating an issue around data failing to load on multiple pages of the application.
Posted Jun 24, 2025 - 23:05 BST
This incident affected: Application / UI.