Platform slowness
Incident Report for Ometria
Resolved
Work to restore service levels has been completed and actions such as estimating recipients are returning results without added delay for those affected.
Posted May 23, 2023 - 03:29 BST
Monitoring
Some clients may face some slowness in some areas of the application.
Our engineers have made improvements and are working to resolve this behaviour
Posted May 22, 2023 - 21:01 BST
This incident affected: Broadcast messages and Application / UI.