Reporting data delayed
Incident Report for Ometria
Resolved
The previously reported delay in report data has now been successfully resolved and all reporting data has been up to date from yesterday evening.
Posted Mar 23, 2023 - 08:52 GMT
Monitoring
We have identified a delay with the generation of statistics that are used in all reports.
Data is currently being processed and we expect this to clear this evening (GB) / afternoon (US).

The team is monitoring to ensure all data is processed as rapidly as possible.
Posted Mar 22, 2023 - 15:15 GMT
This incident affected: Application / UI.